Queer error on publishing contract to TestNet - GasBudgetTooLow and The service currently unavailable at once

Hi Friends!

To try the TestNet I want to publish one of my smart-contracts, simplest one, creating custom coin in the same manner as given in the github example. However I got some queer error, sorry for putting it here in full despite it’s length.Can anyone please share some hints or ideas what may I do wrong?

Below is the beginning, up to “gasbudgettoolow”, full response could be found by this link.

RPC call failed: ErrorObject { code: ServerError(-32000), message: "Transaction has non recoverable errors from at least 1/3 of validators: [(RpcError("error trying to connect: deadline has elapsed", "The service is currently unavailable"),

[k#aaf49ddf1ea0b91a949c24a98bf23e3ef35faffe8bc755713b0558cbbf2555a86d0277723fc1f549cff3cf3175ce151016621e479d0e413d139f199e291ad55ed6ca699fbd8dbe3dde3d587ce7dfab533e4d4efd52903a3447b7675470a31ce4], 43), (UserInputError { error: GasBudgetTooLow { gas_budget: 100000, min_budget: 110 } },


Yes, reported by many.

I believe the MystenLab teams are fixing now so devnet/testnet not available until resolved.


Ah, thanks a lot, I seemingly missed other’s reports if any (or perhaps they are in discord or whatever), sorry if duplicate. Thank you very much for clarification!


Ye I’m waiting patiently for any updates, and none of the apps show up at the moment like the games. @Rodion_at_Chirp


Hey try to change your env to one of the RPC urls mentioned in #node-annoucements

Try these commands in order then try publishing again:

sui client new-env --alias permatestnet --rpc https://fullnode.testnet.vincagame.com:443/
sui client switch --env permatestnet

let me know if that works. If not then try to up your gas budget to something like -500000

1 Like

Hi Friend!

Thanks for suggestion!

Tried adding another env into clients.yaml with the url you provided. Publishing via it yields the same error.

Meanwhile I noticed reported api version there is 0.29.2, not 0.29.3 as on the “default” testnet fullnode url. Devnet also shows 0.29.2 and publish there works all right.

UPD: let here be the link to the package as published on devnet. I’m pretty sure there is nothing special about it, though.