Call api unsafe_movecall

Hello Sui’tech
I tried to call request api to method: “unsafe_moveCall”. But the response is “Could not resolve function Mint in module genesis”
Could you explain why and tell me how to fix it. Thanks
Trasaction success

My body raw data:



Well, the package with genesis::mint is either on testnet or devnet. Make sure you are pointing to the “net” where the package is deployed.

And the first parameter you pass is a sender Address, not a private key.

the first parameter is the transaction signer’s Sui address ( signer ), follow on this doc

And the package on testnet, you can see the transaction that I attach on.

Thank you

The contract is here: contract.
And it works on testnet on Sui Wallet, but i have no idea why when i call api, the result is “Could not resolve function Mint in module genesis”. I think the arguments have problem but i don’t know why

This is my rpc:

1 Like

Really sui system is working fine all devloper waiting for sui mainnet 03 May 2023.
Thanks for awesome project :smiling_face_with_three_hearts::smiling_face_with_three_hearts::pray::pray::pray:

so how about my question sir ? Thank you

You have function Mint but it should be lower case mint

Secondly, unsafe_moveCall works for public entry fun and mint is not. You can, however; invoke the mint function from a Programmable Transaction. Have you tried that?