Error trying to call smartcontract function

I published 3 differents package to the testnet while following the basic move tutorial

And when I try to call a function i consistently have the same error

Transaction failed

[WALLET.SIGN_TX_ERROR] Transaction failed with the following error. Error checking transaction input objects: DependentPackageNotFound { package_id: 0xdd21acdfbf5ab38a81e746477c14a8921fd2fbee353454315395c7d060ca277e }

you can actually try to call the function yourself on suivision, using testnet and this package id: 0xdd21acdfbf5ab38a81e746477c14a8921fd2fbee353454315395c7d060ca277e
Here is Move.toml: gist.github[dot]com/0xGoenka/ec36a82abef616dad7d3b72cc7bd8904

here is hello_world.move: gist.github[dot]com/0xGoenka/ce628a38b07c6f297628f250700567fa

I’ve been stuck on this for quite a long time now lol, and would greatly appreciate your help <3

1 Like

Hi @Goenka,

Let’s try to see what’s not working here.

Here is what I tried to do on testnet. I created a new move project, then copied your Move.toml file, and your hello_world.move file, then called sui move build and then sui client publish ".". I made sure I had enough testnet tokens (sui client gas), and if you do not have, then get some using sui client faucet.

Below you will find a gist with all the files and commands that I run.

When you run sui client publish, you want to look for the Published Objects: PackageID section of the Object Changes table. That will be your package ID that you need to use. Double check that indeed you got the right one.

Also, make sure that you are executing the wallet transaction on the same network as where the package was deployed.