SUI Client - Issue during call

Hi Fam

I am currently building on Sui and have encountered a problem with Sui client. I have tried multiple approaches to resolve the issue, but not successful.

Rn i am trying to call a swap btw SUI & SPEPE on sui client with :

sui client call --function swap_exact_input --module router --package 0xb24b6789e088b876afabca733bed2299fbc9e2d6369be4d1acfa17d8145454d9 --args “0x0000000000000000000000000000000000000002” “0xebbf537bc3686be32fe22b498b42715641bbb209267be72236a352e0444cc5df” “5000000000” “1000000000” --gas-budget 3000000

it returns me :
ObjectID hex string must start with 0x.

i tried to change sui adress to 0x2 and 0x0000000000000000000000000000000000000002::sui::SUI same for pepe but always the same issue, what am I doing wrong ?

Help would be greatly appreciated.


someone please help Boolibun

1 Like

Hello. I also get the error “ObjectID hex string must start with 0x.” and this error has been resolved.

The problem is in your “move call” command. ObjectID is neither 0x2 nor 0x0000000000000000000000000000000000000000002::sui::SUI. Which is the ID of the Object in the module that executes your function.