No such file or directory (os error 2) - error upon publishing simple package

I’m working through the sui tutorial for the distributed counter.

I run into a “file not found” error when publishing the package. With my current setup I have published packages on testnet before, yet here something throws a file not found error, that is little instructive.
I’ve checked the path !

Here is my command run from the “move” directory. It includes a “skip-dependency-verification” flag, due to my current version of sui client, yet the error was there even before.

move git:(main) ✗ sui client publish --gas-budget 10000000000 --skip-dependency-verification counter
[warn] Client/Server api version mismatch, client api version : 1.24.0, server api version : 1.24.1
BUILDING counter
Skipping dependency verification
No such file or directory (os error 2)

Here is my fork of the repositories code.

The “No such file or directory (os error 2)” is not very instructive, and I can’t seem to find any prior instance on the web.

I’d appreciate any suggestions. Best Gordon

A fresh install of sui solved the problem. I had Sui installed via “brew”. I couldn’t find the lastest versions of Sui on “brew”, yet installing with “cargo” didn’t seem to have an effect. I then uninstalled sui completly with “brew”, and did a fresh install with “cargo”. This did the job somehow.

1 Like